Skip to content

Generated install-config fails validation with latest installer #735

Description

@hardys

Describe the bug
Since openshift/installer#2140 landed there are additional checks on the VIP IPs, which fail in our default dev-scripts setup like:

level=fatal msg="failed to fetch Master Machines: failed to load asset "Install Config": invalid "install-config.yaml" file: [platform.baremetal.apiVIP: Invalid value: "192.168.111.5": the virtual IP is expected to be in 10.0.0.0/16 subnet, platform.baremetal.ingressVIP: Invalid value: "192.168.111.4": the virtual IP is expected to be in 10.0.0.0/16 subnet, platform.baremetal.dnsVIP: Invalid value: "192.168.111.2": the virtual IP is expected to be in 10.0.0.0/16 subnet]"
make: *** [ocp_run] Error 1

Maybe @bcrochet has some patch already from when this was tested, but I guess we need to set the subnet to overlap with the VIP IPs in ocp_install_env.sh

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions