Is there an existing issue for this?
Describe the bug
I have the same situation as #9634
The issue was closed with a claim that the error message is logged somewhere, but I cannot see any error:
- The Dashboard shows that the service is running, even though the proxy wasn't started.
- The AppHost logs doesn't show any warning or error - there are just the typical info messages and everything seems OK.
- I cannot find any other place where I could see any information that the proxy cannot start because the port is occupied or is in excluded port ranges.
Expected Behavior
I would expect to see some warning either in AppHost logs or in the Aspire dashboard.
Steps To Reproduce
- Use any template with a single web app.
- Run
netsh interface ipv4 show excludedportrange protocol=tcp to list the excluded port ranges.
- Pick any port from that range and use it in
launchSettings.json:
{
"profiles": {
"https": {
"commandName": "Project",
"launchBrowser": true,
"environmentVariables": {
"ASPNETCORE_ENVIRONMENT": "Development"
},
"applicationUrl": "https://localhost:50500"
}
}
}
Exceptions (if any)
No response
Aspire doctor output
Anything else?
- .NET 10.0
- Aspire 13.5.3
- Windows 11 (latest updates installed)
Is there an existing issue for this?
Describe the bug
I have the same situation as #9634
The issue was closed with a claim that the error message is logged somewhere, but I cannot see any error:
Expected Behavior
I would expect to see some warning either in AppHost logs or in the Aspire dashboard.
Steps To Reproduce
netsh interface ipv4 show excludedportrange protocol=tcpto list the excluded port ranges.launchSettings.json:Exceptions (if any)
No response
Aspire doctor output
Anything else?